RMIS Website SCAC Issues
Incident Report for RMIS
Resolved
RMIS has identified and corrected the issue with the SCAC codes. - JM
Posted Sep 10, 2018 - 12:14 PDT
Investigating
RMIS is currently experiencing issues with SCAC codes, and is proactively working to resolve as soon as possible. We will continue to provide further updates on the status. -JM
Posted Sep 10, 2018 - 11:24 PDT
This incident affected: Web.