RMIS experiencing issues with inbound calls
Incident Report for RMIS
Resolved
This incident has been resolved.
Posted May 21, 2018 - 12:12 PDT
Monitoring
Our telecom provider has implemented a fix, and all inbound calls appear to be routing properly. RMIS will continue to monitor the situation. -PL
Posted May 21, 2018 - 11:07 PDT
Investigating
RMIS is experiencing issues with inbound calling. We are working with our telecom vendor to determine the issue. In the meantime, please contact us using our online chat or email:
Transportation: help@rmis.com
Property Management: questions@rmis.com
-PL
Posted May 21, 2018 - 10:02 PDT
This incident affected: Phone.