Credit Card processing - Property Management
Incident Report for RMIS
Resolved
We are happy to report that all online payment processing has been restored and is operating normally. Thank you for you patience!
Posted about 1 month ago. Apr 14, 2017 - 09:10 PDT
Update
RMIS has identified a problem with our online credit card payment processing. If you are attempting to make a payment for a registration, please call 866-396-1105 and an RMIS representative can complete you payment and registration over the phone. Thank you for your patience.
Posted about 1 month ago. Apr 14, 2017 - 08:14 PDT
Identified
RMIS has identified an error occurring while trying to process Credit Card information. If you are attempting to make a payment, please email Questions@rmis.com and a representative will call you as soon as the issue is resolved. - MM
Posted about 1 month ago. Apr 14, 2017 - 07:03 PDT