Email Delays - Vendor repairs in progress.
Incident Report for RMIS
Resolved
Our email vendor reports that emails are no longer being delayed. --JP
Posted Jul 14, 2017 - 06:15 PDT
Investigating
RMIS is aware that all of our email accounts are experiencing delays with both send and receive. The delay is causing emails to take up to an hour to process. Our email vendor is aware of the issue and is investigating. This is effecting our Help@ and Questions@ emails as well and responses may be slower than usual. - JP
Posted Jul 13, 2017 - 07:55 PDT