IRS TIN Matching is Degraded/Down
Incident Report for RMIS
Resolved
RMIS is now successfully processing all IRS TIN Matching, and all W9 TIN match backlogs are cleared.

Please be aware: over the weekend of 9/7/19, the IRS made fundamental changes to their TIN matching interface that required changes to the RMIS system. Unfortunately, the IRS interface updates will change how quickly RMIS is able to query the IRS system and return TIN matching pass/fail statuses.

In the past, RMIS was able to process a W9 validation within approximately 15 minutes of the W9 submission. With the new IRS interface, the time between submission and validation will now be longer. Our experience so far indicates an average W9 matching result to now take between 90 and 120 minutes.

We understand the urgency of W9 TIN match processing for our customers, and we are doing our best to provide the best service possible within the constraints of the IRS interface. If you have any concerns, please contact us at help@rmis.com and we can discuss options. - PL
Posted 9 days ago. Sep 11, 2019 - 13:54 PDT
Update
RMIS is continuing to process W9s through the IRS TIN Match process successfully. Unfortunately the IRS system is operating more slowly than normal. RMIS is working to clear the backlog of TIN matches as quickly as possible. - PL
Posted 11 days ago. Sep 10, 2019 - 05:48 PDT
Update
RMIS has resumed the TIN Matching process, and is now running through the backlog of electronic W9s. -JM
Posted 11 days ago. Sep 09, 2019 - 13:07 PDT
Identified
The IRS e-Services system, which includes TIN Matching is currently down. Until the IRS system is corrected, RMIS will be unable to validate W9 TIN Matches. RMIS will continue to monitor the situation. -PL
Posted 12 days ago. Sep 09, 2019 - 05:36 PDT
This incident affected: IRS TIN Matching.