RMIS Payment Technical Issue
Incident Report for RMIS
Resolved
This incident has been resolved 10:20AM CST. We will continue to monitor to ensure there are no additional interruptions. Thank you for your patience. -BE
Posted Jan 21, 2022 - 09:16 PST
Identified
We are currently experiencing a technical issue processing payments for our Property Management customers. If you are visiting to register or renew your payment, please try again later today. All other RMIS systems and website functionality are operational. We apologize for the inconvenience. - BE
Posted Jan 21, 2022 - 06:49 PST
This incident affected: Web.