Issue with RMIS Payment Processing
Incident Report for RMIS
Resolved
Our RMIS payment processing is up and running. Thank you for your patience as we resolved this issue with our banking processor. - BE
Posted Jan 20, 2022 - 11:01 PST
Identified
We are experiencing an issue with processing payments for of our web and phone transactions. The issue as an outage with banking processer.
We are waiting for an update from the processor and will provide an update when more information is available. All other RMIS systems are operational. We apologize for the inconvenience. - BE
Posted Jan 20, 2022 - 08:37 PST
This incident affected: Web.