Power Outage At RMIS Facility
Incident Report for RMIS
Resolved
Utility power to the RMIS offices has been restored. All systems are operating normally. - PL
Posted Sep 28, 2020 - 03:04 PDT
Identified
The RMIS offices are currently experiencing a utility power outage. RMIS has successfully transitioned to our backup power systems, and all systems are operating normally. -PL
Posted Sep 28, 2020 - 01:46 PDT
This incident affected: RMIS Physical Facility.