CSA Data Processing Delay - Impacting Carrier Profiles
Incident Report for RMIS
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 15:33 PST
Investigating
We are aware that the CSA information for carriers is currently outdated. We are working on updating this information as quickly as possible.
Posted Nov 17, 2023 - 12:12 PST
This incident affected: Web.