Issue with RMIS Credit Card processing
Incident Report for RMIS
Resolved
Our credit card processor has recovered and all payments are processing properly. - PL
Posted Jul 28, 2021 - 13:16 PDT
Identified
We are experiencing an issue with processing credit cards for of our web and phone transactions. We have identified the issue as an outage with our credit card processor. We are waiting for an update from the processor and will provide an update when more information is known. All other RMIS systems are operational. We apologize for the inconvenience. - PL
Posted Jul 28, 2021 - 12:19 PDT
This incident affected: Web.