Delays in Support Email Responses
Incident Report for RMIS
Resolved
This incident has been resolved.
Posted Oct 29, 2024 - 06:39 PDT
Investigating
We are currently experiencing an issue with our support mailboxes where incoming emails are not generating cases as expected. Please rest assured that we have received all support emails; however, our responses may be delayed while we work to resolve this issue.
Our team is aware of the issue and is working to resolve it.
Posted Oct 28, 2024 - 10:39 PDT
This incident affected: Email.