Power Outage At RMIS Facility
Incident Report for RMIS
Resolved
Power has been restored to the facility, all systems are operational. -PL
Posted Jul 19, 2021 - 06:42 PDT
Investigating
RMIS is experiencing a power outage out our Westlake Village facility. We are investigating with our utility and will provide updates shortly. Currently all RMIS systems are operational. - PL
Posted Jul 19, 2021 - 05:59 PDT
This incident affected: RMIS Physical Facility.