RMIS Priority Insurance Certificate Delay
Incident Report for RMIS
Resolved
This incident has been resolved.
Posted Jan 05, 2024 - 13:59 PST
Update
We are continuing to investigate this issue.
Posted Jan 05, 2024 - 13:48 PST
Investigating
We ware aware that RMIS customers sending priority insurance certificates may be delayed.  The team is aware and working to resolve as quickly as possible.
Posted Jan 05, 2024 - 13:47 PST
This incident affected: Email.