Identity Verification Request Issue

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 15:05 PST

Investigating

New customers may experience intermittent issues with Identity Verification (IDV) requests. Our team is aware and actively working to restore service as quickly as possible. This issue does not impact access to any Truckstop products.
Posted Jan 28, 2026 - 11:15 PST
This incident affected: Web.