TIN Matching Delay

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 08:14 PST

Investigating

The IRS is running slow causing intermittent issues with customers verifying the carriers TIN matching.
Posted Feb 18, 2026 - 15:50 PST
This incident affected: IRS TIN Matching.