RMIS COVID-19 UPDATE
Incident Report for RMIS
Resolved
This incident has been resolved.
Posted Jan 21, 2022 - 06:51 PST
Monitoring
We would like to take a moment to let our customers know that during these unsettling times, RMIS is open and fully operational. RMIS has implemented our Emergency Preparedness Plan, which has been in place for natural or other disasters. Tonight, our California governor issued a 'stay at home' order requiring residents to remain in their homes. RMIS has relocated our staff to work from their homes and will continue to provide our services to all customers without interruption. We appreciate your support during these unprecedented times and we remain dedicated to providing you the best service possible during these rapidly changing conditions.
Posted Mar 19, 2020 - 20:17 PDT
This incident affected: Phone, Email, and Chat.