FMCSA Data Services

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 16:09 PST

Investigating

We are currently experiencing issues with FMCSA data services, which may result in stale customer data. We are actively working to resolve it as quickly as possible.
Posted Feb 17, 2026 - 14:28 PST
This incident affected: DOT / FMCSA.