Carrier Assure Issue

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 18:10 PST

Investigating

We are aware that the RMIS and Carrier Assure integration is currently not working.. We are investigating the issue, and will restore the service as soon as possible.
Posted Dec 05, 2025 - 08:14 PST
This incident affected: Web.