RMIS - Carrier Registration Issue - Degraded
Incident Report for RMIS
Resolved
This incident has been resolved.
Posted Jan 20, 2023 - 11:18 PST
Identified
The team has identified the issue and we are currently implementing a resolution.
Posted Jan 20, 2023 - 10:59 PST
Investigating
We are aware carriers are currently unable to register with brokers who include the Diversity Questionnaire in their registration process. This page is currently showing an error when carriers attempt to proceed. Our team is aware and is working to resolve as quickly as possible.
Posted Jan 20, 2023 - 10:33 PST
This incident affected: Web.