RESOLVED - RMIS Email Delays

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted May 23, 2023 - 08:31 PDT

Investigating

We are aware of an issue where emails sent via RMIS may see delays caused by an outbound email provider. This may impact carrier registrations. Our RMIS team is working diligently with our vendor and we will provide updates as soon as they become available.
Posted May 23, 2023 - 06:54 PDT
This incident affected: Email.