Intermittent Telephone Connectivity

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Feb 17, 2020 - 06:30 PST

Investigating

The RMIS phone provider has advised there are fiber connectivity issues affecting our area.
We are currently working with the phone provider to resolve this matter ASAP.

GS
Posted Feb 14, 2020 - 06:37 PST
This incident affected: Phone.