FMCSA Data Updates
Incident Report for RMIS
Resolved
This incident has been resolved.
Posted Feb 04, 2025 - 11:05 PST
Investigating
We would like to inform you that the FMCSA implemented significant updates to its data over the weekend, resulting in changes for all carriers. As a result, you may notice an increased volume of updates over the next few days. We appreciate your understanding and patience during this time. Thank you for your continued partnership.
Posted Jan 28, 2025 - 10:50 PST
This incident affected: DOT / FMCSA.