RMIS offices experiencing power outage
Incident Report for RMIS
Resolved
Power to the RMIS offices has been restored. All systems are up and running normally. -PL
Posted Apr 03, 2020 - 08:24 PDT
Identified
Please be aware that the RMIS offices are experiencing a power outage and are on emergency backup power. All websites, APIs and automated systems are up and OK. We will provide updates here when have more information about the duration of the outage. - PL
Posted Apr 03, 2020 - 08:01 PDT
This incident affected: Phone, Email, and Chat.