IDV Center and Verification Issue

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 11:21 PDT

Investigating

Currently, customers are unable to access Identity Verification Center or send invites to carriers to verify identity through IDV. This issue does not impact access to any Truckstop products.
Posted Apr 11, 2025 - 09:36 PDT