RMIS Update Delay - AM Best Data Change

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Sep 07, 2023 - 06:58 PDT

Investigating

We are aware that unannounced changes in AM Best's data feed have impacted the latest update to underwriter ratings in RMIS. The team is actively working to accommodate these changes and will have the updated data posted as quickly as possible.
Posted Sep 01, 2023 - 09:16 PDT
This incident affected: API.