RMIS Carrier Contact Info
Incident Report for RMIS
Resolved
This incident has been resolved.
Posted Jan 22, 2024 - 14:51 PST
Investigating
Please be aware that the carrier contact information currently in RMIS is valid as of the previous DOT contact list. We are working to fully update this data to be reflective of current contact information.
Posted Jan 18, 2024 - 11:00 PST
This incident affected: DOT / FMCSA.