RMIS Carrier Onboarding SCAC Code Issue

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Jun 01, 2022 - 07:38 PDT

Investigating

We are aware some customers are not seeing the SCAC code appearing within the carrier's registration. Our team is working diligently with our vendor to resolve this issue. We will provide updates as quickly as their is available. Thank you for your patience.
Posted May 25, 2022 - 07:45 PDT
This incident affected: Web.