RMIS Phone System Disruption
Incident Report for RMIS
Resolved
This incident has been resolved.
Posted Jun 13, 2022 - 13:54 PDT
Identified
RMIS phone systems are currently down which is impacting the ability for customers to call in.. Our team is working diligently with the vendor to resolve it as quickly as possible. Please contact us via chat by going to https://rmis.com/support or email us at rmishelp@truckstop.com or for PM customers, contact us at questions@rmis.com. Thank you for your patience.
Posted Jun 13, 2022 - 09:07 PDT
This incident affected: Phone.