RMIS Carrier Registration Emails

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 07:05 PDT

Investigating

We are aware that customers are not receiving the registration alert emails after a carrier completes registration. We are investigating the issue.
Posted Aug 06, 2025 - 07:32 PDT
This incident affected: Web and API.