Census Data Delay

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Oct 29, 2024 - 06:38 PDT

Investigating

We are aware that some RMIS customers are currently experiencing delays in accessing the latest census data within Carrier Details and Matrix Engine. The team is working to resolve this issue as quickly as possible.
Posted Oct 25, 2024 - 10:29 PDT
This incident affected: Web.